YAPI Service System Requirements

YAPI is designed to operate on many systems, with various software and hardware combinations. YAPI work appropriately on the following systems and setups:

Supported Operating Systems
Windows 7 Professional, Enterprise, Ultimate
Windows 8  Professional, Enterprise
Windows 8.1 Professional, Enterprise
Windows 10 Professional, Enterprise
Windows Server 2008* Standard, Enterprise, Datacenter
Windows Server 2008 R2* Standard, Enterprise, Datacenter
Windows Server 2012 Standard, Enterprise, Datacenter
Windows Server 2012 R2 Standard, Enterprise, Datacenter
Windows Server 2016 Standard, Enterprise, Datacenter

* Windows 2008 systems must undergo the applicable windows update (KB4019276) to enable TLS 1.2 to interact appropriately with the YAPI software

Hardware Requirements
  Minimum Requirements Recommended Requirements
CPU Dual Core Processor Quad Core Processor
RAM 4 GB 8 GB
Disk Space 600 mb 10 GB

 

For YAPI to communicate with the server appropriately, the following exceptions need to be created to the Windows Firewall settings:

Firewall Exceptions
TCP Inbound Ports 80, 443, 587, 18000-18009, 18800, 18802
TCP Outbound Ports 80, 443, 587, 18000-18009, 18800, 18802
UDP Inbound Ports 3520, 18002
UDP Outbound Ports 3520, 18002

 

Additional Notes
  • Only 1 YAPI Service can be installed per server/database

  • Environmental conditions such as Anti-virus, Active Directory Group Policies, DNS Service, and/or Email Services can impact the performance and specifications required

  • It is not recommended to use the server as a workstation

Note: For system requirements regarding YAPI Workstations on each user's computer, please visit the article YAPI Workstation System Requirements

Was this article helpful?
1 out of 3 found this helpful